Modify

Opened 9 years ago

Closed 6 years ago

Last modified 4 years ago

#2966 closed enhancement (fixed)

Add user account edit support to "Manage User Accounts" page (without extending user details)

Reported by: myingling Owned by: Steffen Hoffmann
Priority: normal Component: AccountManagerPlugin
Severity: major Keywords: user account admin
Cc: hju@…, Heikki Toivonen (remove -bugzilla when emailing directly), David Rees Trac Release: 0.11

Description

This plugin is one of the reasons I'm using Trac instead of some other solution.

The plugin lets the administrator add new users and specify email addresses, but only the user can update his or her email address. It would be great if the administrator could also edit email addresses (and name and password). They can be changed now if the account is deleted and recreated, but that's a bit more of a hassle.

Attachments (0)

Change History (18)

comment:1 Changed 9 years ago by hju

Cc: hju@… added; anonymous removed

Looking for an opportunity to admin accounts I found this ticket. I'm very interested in the progress of this enhancement so I have added my eMail.

comment:2 Changed 9 years ago by Heikki Toivonen (remove -bugzilla when emailing directly)

Cc: Heikki Toivonen (remove -bugzilla when emailing directly) added

comment:3 Changed 8 years ago by anonymous

Yes, I'm interested in this too...

comment:4 Changed 8 years ago by anonymous

Definately a nice to have feature.

comment:6 Changed 8 years ago by David Rees

Cc: David Rees added

I'm also interested in this...

comment:7 Changed 8 years ago by anonymous

Priority: normalhigh

comment:8 Changed 8 years ago by anonymous

Summary: Add email edit support to "Manage User Accounts" pageAdd user account edit support to "Manage User Accounts" page
Trac Release: 0.100.11

me too. anyone?

comment:9 Changed 7 years ago by shubham_chakraborty@…

Severity: normalmajor

Is there any way or any plugin to edit user details by any means by the admin ???

comment:10 in reply to:  description Changed 7 years ago by Steffen Hoffmann

Keywords: user account admin added
Owner: changed from Matt Good to Steffen Hoffmann

Replying to myingling:

This plugin is one of the reasons I'm using Trac instead of some other solution.

Great. BTW, I feel the same, and this was the main reason for taking over maintainership to improve the bad support for it.

The plugin lets the administrator add new users and specify email addresses, but only the user can update his or her email address. It would be great if the administrator could also edit email addresses (and name and password). They can be changed now if the account is deleted and recreated, but that's a bit more of a hassle.

Clearly meanwhile there has been some improvements, since it's possible now to set a (new) password for any user via the account admin page.

comment:11 Changed 7 years ago by Steffen Hoffmann

Priority: highnormal
Summary: Add user account edit support to "Manage User Accounts" pageAdd user account edit support to "Manage User Accounts" page (without extending user details)

Replying to shubham_chakraborty@infosys.com:

Is there any way or any plugin to edit user details by any means by the admin ???

Yes, it's there:

UserManagerPlugin explicitly states, that it is build on top of AccountManagerPlugin to provide this functionality. So I don't see the need to to the same or similar thing within AccountManagerPlugin itself, with one exception: I'll see, if it is feasible to add administrative account details edit support AccountManagerPlugin without extending the set of user data as much as UserManagerPlugin does.

Anyway thanks for the strong interest in AccountManagerPlugin shown here.

comment:12 Changed 6 years ago by Steffen Hoffmann

#8710 has been closed as a duplicate of this ticket. This is obviously a requested feature.

comment:12 Changed 6 years ago by Steffen Hoffmann

(In [10290]) AccountManagerPlugin: Extend property editor in user-admin page, refs #2966.

Historically there have been two separate forms, one for user creation and another one dedicated to changing/resetting a users password. This was flawed for long, because password change attempts on non-existing users created them silently bypassing all the checks normally enforced on user creation.

Now let's have just one form to rule them all. ;-) Enjoy.

comment:13 Changed 6 years ago by Steffen Hoffmann

Status: newassigned

I'm quite eager to learn about your usage experience with the new property editor side-panel. Let me know, if it's good enough for integration into the next AcctMgr (0.3) release, please.

comment:14 Changed 6 years ago by Steffen Hoffmann

Resolution: fixed
Status: assignedclosed

(In [10393]) AccountManagerPlugin: Releasing version 0.3, pushing development to 0.4.

This new feature release finally propagates a number of solutions into an official release, after some time of testing with trunk, so explicitely closes #442, #816, #2966, #3989, #4160, #6821, #7111, #8534, #8549, #8663, #8813, #8892, #8925, #8936 and #8939.

Should have made this months ago, but felt so many pending issues were too bad for a new release. But it has been a tremendous ticket burndown since last year, so it's really worth considering an upgrade now. See fresh changelog for details.

comment:15 Changed 6 years ago by Steffen Hoffmann

(In [10395]) AccountManagerPlugin: Releasing version 0.3, pushing development to 0.4.

This new feature release finally propagates a number of solutions into an official release, after some time of testing with trunk, so explicitely closes #442, #816, #2966, #3989, #4160, #6821, #7111, #8534, #8549, #8663, #8813, #8892, #8925, #8936 and #8939.

Should have made this months ago, but felt so many pending issues were too bad for a new release. But it has been a tremendous ticket burndown since last year, so it's really worth considering an upgrade now. See fresh changelog for details.

comment:16 in reply to:  13 Changed 4 years ago by Steffen Hoffmann

Replying to hasienda:

I'm quite eager to learn about your usage experience with the new property editor side-panel. Let me know, if it's good enough for integration into the next AcctMgr (0.3) release, please.

Judging from implicit feedback by requests about the way to do account changes with AccountManager I deduce, that the all-in-one approach actually doesn't work at least for some people. While its powerful, it is not as intuitive on first sight. As the designer I can handle it just fine, sure. But hands down, the KISS principle of doing things is the ultimate goal for every component of Trac. My point of view. So try what I came up with as a conclusion, please.

comment:17 Changed 4 years ago by Steffen Hoffmann

(In [13053]) AccountManagerPlugin: Improve the account properties editor, refs #2966.

Move account edit functionality into account details page for consistency. Editing users now works like editing ticket priorities, types etc., and the account property editor is looking clearer, modular and more self-explaining.

A focus has been on performance and simplification too, so please note visible and code changes like

  • username becoming part of the admin page URL for distinct user's properties just like Trac core does for managing resources and enums
  • replacement of an iteration over self.env.get_known_users() with a straight query on one user's attributes
  • cleaned _do_acct_details method and admin panel templates

comment:18 Changed 4 years ago by Steffen Hoffmann

Make sure to check for following related changes before/on next release, because I still have some more ideas for this part of the web-UI.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Steffen Hoffmann.
The resolution will be deleted. Next status will be 'reopened'.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.